summaryrefslogtreecommitdiff
path: root/server/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'server/default.nix')
-rw-r--r--server/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/server/default.nix b/server/default.nix
new file mode 100644
index 0000000..5826f0c
--- /dev/null
+++ b/server/default.nix
@@ -0,0 +1,26 @@
+{ mkDerivation, aeson, async, base, base-compat, base64-bytestring
+, bytestring, containers, cryptohash-sha1, directory, extra
+, filepath, fmt, getopt-generics, http-client, http-types, lib
+, lucid, microlens-platform, monad-logger, process, servant
+, servant-client, servant-lucid, servant-server, servant-websockets
+, stm, text, time, tomland, universum, uuid, wai, wai-extra, walint
+, warp, websockets
+}:
+mkDerivation {
+ pname = "walint-server";
+ version = "0.1";
+ src = ./.;
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson async base base-compat base64-bytestring bytestring
+ containers cryptohash-sha1 directory extra filepath fmt
+ getopt-generics http-client http-types lucid microlens-platform
+ monad-logger process servant servant-client servant-lucid
+ servant-server servant-websockets stm text time tomland universum
+ uuid wai wai-extra walint warp websockets
+ ];
+ homepage = "https://stuebinm.eu/git/walint";
+ license = "unknown";
+ mainProgram = "walint-server";
+}