summaryrefslogtreecommitdiff
path: root/server/default.nix
diff options
context:
space:
mode:
authorstuebinm2023-10-23 23:18:34 +0200
committerstuebinm2023-10-24 01:21:52 +0200
commit9110064fe62f98dd3ecc5fb4c3915a843492b8fb (patch)
tree6a8e3d54bef365bf1c6c4f72a7a75dd5d1f05d40 /server/default.nix
parenta4461ce5d73a617e614e259bfe30b4e895c38a19 (diff)
a year went byHEADmain
This does many meta-things, but changes no functionality: - get rid of stack, and use just cabal with a stackage snapshot instead (why did I ever think stack was a good idea?) - update the stackage snapshot to something halfway recent - thus making builds work on nixpkgs-23.05 (current stable) - separating out packages into their own cabal files - use the GHC2021 set of extensions as default - very slight code changes to make things build again - update readme accordingly - stylish-haskell run
Diffstat (limited to 'server/default.nix')
-rw-r--r--server/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/server/default.nix b/server/default.nix
new file mode 100644
index 0000000..5826f0c
--- /dev/null
+++ b/server/default.nix
@@ -0,0 +1,26 @@
+{ mkDerivation, aeson, async, base, base-compat, base64-bytestring
+, bytestring, containers, cryptohash-sha1, directory, extra
+, filepath, fmt, getopt-generics, http-client, http-types, lib
+, lucid, microlens-platform, monad-logger, process, servant
+, servant-client, servant-lucid, servant-server, servant-websockets
+, stm, text, time, tomland, universum, uuid, wai, wai-extra, walint
+, warp, websockets
+}:
+mkDerivation {
+ pname = "walint-server";
+ version = "0.1";
+ src = ./.;
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson async base base-compat base64-bytestring bytestring
+ containers cryptohash-sha1 directory extra filepath fmt
+ getopt-generics http-client http-types lucid microlens-platform
+ monad-logger process servant servant-client servant-lucid
+ servant-server servant-websockets stm text time tomland universum
+ uuid wai wai-extra walint warp websockets
+ ];
+ homepage = "https://stuebinm.eu/git/walint";
+ license = "unknown";
+ mainProgram = "walint-server";
+}