summaryrefslogtreecommitdiff
path: root/utils/Cargo.toml
diff options
context:
space:
mode:
authorstuebinm2021-04-12 17:11:14 +0200
committerstuebinm2021-04-12 17:11:14 +0200
commitd3607cf2c5f06f95a7309df5dfb5167cac5d45c1 (patch)
tree110716cfdd7748fafe9d58597db67f4da8e91c84 /utils/Cargo.toml
parent6b892239f80e8523e02d7348e5483e9a7aea58ee (diff)
utils: use dhall substitutes for config typesdhall-substitutes
this uses my own version of dhall_rust [1], which has actual support for adding in new types in rust code, which are derived via serde, instead of just gluing in extra code for every file that is read in (in particular, this results in actually useful error messages).
Diffstat (limited to 'utils/Cargo.toml')
-rw-r--r--utils/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/utils/Cargo.toml b/utils/Cargo.toml
index e959f55..a254855 100644
--- a/utils/Cargo.toml
+++ b/utils/Cargo.toml
@@ -8,7 +8,8 @@ edition = "2018"
[dependencies]
serde = { version = "1.0", features = [ "derive" ] }
-serde_dhall = "0.10.0"
+#serde_dhall = "0.10.0"
+serde_dhall = { path = "../../playground/dhall-rust/serde_dhall" }
serde_json = "1.0.64"
age = "0.5.1"
structopt = "0.3.21"