aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorstuebinm2021-03-07 16:57:23 +0100
committerstuebinm2021-03-07 16:58:51 +0100
commit2ad5d413aa958a1c2fe75ce7aa155576e9a80345 (patch)
treedb48dfb66bd086fb3d7f951a15be6cb7b4bae7f7 /default.nix
parent3b15d761ce7159ab1669817d6cf64550db8dd23f (diff)
Add server to general repository
Idea: have all components of this program in one repository
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix33
1 files changed, 0 insertions, 33 deletions
diff --git a/default.nix b/default.nix
deleted file mode 100644
index ebcb880..0000000
--- a/default.nix
+++ /dev/null
@@ -1,33 +0,0 @@
-{ nixpkgs ? import <nixpkgs> {}, compiler ? "default", doBenchmark ? false }:
-
-let
-
- inherit (nixpkgs) pkgs;
-
- f = { mkDerivation, aeson, base, bytestring, stdenv, text
- , unordered-containers, websockets
- }:
- mkDerivation {
- pname = "haskell-ws-test";
- version = "0.1.0.0";
- src = ./.;
- isLibrary = false;
- isExecutable = true;
- executableHaskellDepends = [
- aeson base bytestring text unordered-containers websockets
- ];
- license = "unknown";
- hydraPlatforms = stdenv.lib.platforms.none;
- };
-
- haskellPackages = if compiler == "default"
- then pkgs.haskellPackages
- else pkgs.haskell.packages.${compiler};
-
- variant = if doBenchmark then pkgs.haskell.lib.doBenchmark else pkgs.lib.id;
-
- drv = variant (haskellPackages.callPackage f {});
-
-in
-
- if pkgs.lib.inNixShell then drv.env else drv