aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorstuebinm2021-03-07 16:50:46 +0100
committerstuebinm2021-03-07 16:50:46 +0100
commit3b15d761ce7159ab1669817d6cf64550db8dd23f (patch)
tree5d92b024fd39d3323c6bb7118720c3ba28409a2b /default.nix
parent936dc3d58c9e7f388a2df92c182abeaeca52ce17 (diff)
Added nix build expression
makes a derivation with a functioning server inside of it.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..ebcb880
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,33 @@
+{ nixpkgs ? import <nixpkgs> {}, compiler ? "default", doBenchmark ? false }:
+
+let
+
+ inherit (nixpkgs) pkgs;
+
+ f = { mkDerivation, aeson, base, bytestring, stdenv, text
+ , unordered-containers, websockets
+ }:
+ mkDerivation {
+ pname = "haskell-ws-test";
+ version = "0.1.0.0";
+ src = ./.;
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson base bytestring text unordered-containers websockets
+ ];
+ license = "unknown";
+ hydraPlatforms = stdenv.lib.platforms.none;
+ };
+
+ haskellPackages = if compiler == "default"
+ then pkgs.haskellPackages
+ else pkgs.haskell.packages.${compiler};
+
+ variant = if doBenchmark then pkgs.haskell.lib.doBenchmark else pkgs.lib.id;
+
+ drv = variant (haskellPackages.callPackage f {});
+
+in
+
+ if pkgs.lib.inNixShell then drv.env else drv