summaryrefslogtreecommitdiff
path: root/pkgs/python/s3-tar.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/python/s3-tar.nix')
-rw-r--r--pkgs/python/s3-tar.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/python/s3-tar.nix b/pkgs/python/s3-tar.nix
new file mode 100644
index 0000000..8778bc7
--- /dev/null
+++ b/pkgs/python/s3-tar.nix
@@ -0,0 +1,21 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+, python
+, boto3
+}:
+
+buildPythonPackage rec {
+ pname = "s3-tar";
+ version = "0.1.13";
+ format = "setuptools";
+
+ src = fetchPypi {
+ inherit pname version;
+ hash = "sha256-0LPuK/NYp+mVFUlrlAdrbrsT8kM6WhVfg5Jb1LW9wgU=";
+ };
+
+ propagatedBuildInputs = [
+ boto3
+ ];
+}