summaryrefslogtreecommitdiff
path: root/pkgs/python/s3-tar.nix
diff options
context:
space:
mode:
authorstuebinm2024-11-24 23:44:30 +0100
committerstuebinm2024-11-24 23:44:30 +0100
commit06c6dae0756f1023bbb225c1d70dc5e92dc31808 (patch)
tree2a82766a85073226787a36e5332b8c006080bcdf /pkgs/python/s3-tar.nix
parent65cdc955efa657ec2923c6338a89b8bf6b334e7c (diff)
pkgs/bookwyrm: 0.7.2 → 0.7.4
passes the basic smoke test, nothing else done (doing this to distract myself & since people expressed interest in maybe trying to run an instance again).
Diffstat (limited to 'pkgs/python/s3-tar.nix')
-rw-r--r--pkgs/python/s3-tar.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/python/s3-tar.nix b/pkgs/python/s3-tar.nix
new file mode 100644
index 0000000..8778bc7
--- /dev/null
+++ b/pkgs/python/s3-tar.nix
@@ -0,0 +1,21 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+, python
+, boto3
+}:
+
+buildPythonPackage rec {
+ pname = "s3-tar";
+ version = "0.1.13";
+ format = "setuptools";
+
+ src = fetchPypi {
+ inherit pname version;
+ hash = "sha256-0LPuK/NYp+mVFUlrlAdrbrsT8kM6WhVfg5Jb1LW9wgU=";
+ };
+
+ propagatedBuildInputs = [
+ boto3
+ ];
+}