summaryrefslogtreecommitdiff
path: root/hosts/flora/services/picarones.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/flora/services/picarones.nix')
-rw-r--r--hosts/flora/services/picarones.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/hosts/flora/services/picarones.nix b/hosts/flora/services/picarones.nix
new file mode 100644
index 0000000..06e8ab1
--- /dev/null
+++ b/hosts/flora/services/picarones.nix
@@ -0,0 +1,26 @@
+{config, pkgs, ...}:
+let
+ source = builtins.fetchGit {
+ url = "https://stuebinm.eu/git/picarones/";
+ rev = "393186f9ebf0bf43a1add8bd8d0e37be566ae8cc";
+ };
+in
+{
+
+ imports = [ source.outPath ];
+
+ services.picarones = {
+ enable = true;
+ frontend = {
+ enable = true;
+ domain = "picarones.stuebinm.eu";
+ proxyBackend = true;
+ config = {
+ enableACME = true;
+ forceSSL = true;
+ };
+ };
+ };
+
+ networking.firewall.allowedTCPPorts = [ 80 443 ];
+}