summaryrefslogtreecommitdiff
path: root/hosts/flora/services/picarones.nix
diff options
context:
space:
mode:
authorstuebinm2021-03-09 18:06:53 +0100
committerstuebinm2021-03-09 18:06:53 +0100
commit0fd4d7cafdefe19948e5e517805d4f4636e99f48 (patch)
treedc674b23bde6103c1e0c8658ac0eee132d724057 /hosts/flora/services/picarones.nix
parent6b79492de7467e44733d2644273185af548dc20b (diff)
Added picarones
Just a simple test instance fore now.
Diffstat (limited to 'hosts/flora/services/picarones.nix')
-rw-r--r--hosts/flora/services/picarones.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/hosts/flora/services/picarones.nix b/hosts/flora/services/picarones.nix
new file mode 100644
index 0000000..06e8ab1
--- /dev/null
+++ b/hosts/flora/services/picarones.nix
@@ -0,0 +1,26 @@
+{config, pkgs, ...}:
+let
+ source = builtins.fetchGit {
+ url = "https://stuebinm.eu/git/picarones/";
+ rev = "393186f9ebf0bf43a1add8bd8d0e37be566ae8cc";
+ };
+in
+{
+
+ imports = [ source.outPath ];
+
+ services.picarones = {
+ enable = true;
+ frontend = {
+ enable = true;
+ domain = "picarones.stuebinm.eu";
+ proxyBackend = true;
+ config = {
+ enableACME = true;
+ forceSSL = true;
+ };
+ };
+ };
+
+ networking.firewall.allowedTCPPorts = [ 80 443 ];
+}