summaryrefslogtreecommitdiff
path: root/home/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/home.nix')
-rw-r--r--home/home.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/home/home.nix b/home/home.nix
index ae210b0..23e1abd 100644
--- a/home/home.nix
+++ b/home/home.nix
@@ -105,7 +105,9 @@
feeds = (import inputs.feeds).ical; in {
Unit.Description = "syncs ical feeds for almanac agenda";
Service = {
- ExecStart = "${pkgs.gauche}/bin/gosh ${./scripts/sync.scm} ${lib.fold (a: b: a + " " + b) "" feeds}";
+ ExecStart = (pkgs.writeShellScript "syncical" ''
+ ${pkgs.gauche}/bin/gosh ${./scripts/sync.scm} ${lib.escapeShellArgs feeds}
+ '').outPath;
X-ReloadIfChanged = true;
Environment = ''
PATH=${pkgs.curl}/bin:${pkgs.coreutils}/bin