summaryrefslogtreecommitdiff
path: root/home/home.nix
diff options
context:
space:
mode:
authorstuebinm2023-03-09 02:05:41 +0100
committerstuebinm2023-03-09 02:05:41 +0100
commitef4e4fb6ab8d7c11885c40c82a6ffdf90fbea174 (patch)
tree87678327a6278f715274b199e098c9e7abd75020 /home/home.nix
parentdb5e3e8ae3b2cc23347a3d116be3a8398a180459 (diff)
home: fix the icalsync script
systemd be weird
Diffstat (limited to 'home/home.nix')
-rw-r--r--home/home.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/home/home.nix b/home/home.nix
index ae210b0..23e1abd 100644
--- a/home/home.nix
+++ b/home/home.nix
@@ -105,7 +105,9 @@
feeds = (import inputs.feeds).ical; in {
Unit.Description = "syncs ical feeds for almanac agenda";
Service = {
- ExecStart = "${pkgs.gauche}/bin/gosh ${./scripts/sync.scm} ${lib.fold (a: b: a + " " + b) "" feeds}";
+ ExecStart = (pkgs.writeShellScript "syncical" ''
+ ${pkgs.gauche}/bin/gosh ${./scripts/sync.scm} ${lib.escapeShellArgs feeds}
+ '').outPath;
X-ReloadIfChanged = true;
Environment = ''
PATH=${pkgs.curl}/bin:${pkgs.coreutils}/bin