summaryrefslogtreecommitdiff
path: root/home/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/home.nix')
-rw-r--r--home/home.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/home/home.nix b/home/home.nix
index 1846e12..d48c162 100644
--- a/home/home.nix
+++ b/home/home.nix
@@ -108,7 +108,13 @@
systemd.user.services.syncical = let
feeds = (import inputs.feeds).ical; in {
Unit.Description = "syncs ical feeds for almanac agenda";
- Service.ExecStart = "${./scripts/sync.scm} ${lib.fold (a: b: a + " " + b) "" feeds}";
+ Service = {
+ ExecStart = "${pkgs.gauche}/bin/gosh ${./scripts/sync.scm} ${lib.fold (a: b: a + " " + b) "" feeds}";
+ X-ReloadIfChanged = true;
+ Environment = ''
+ PATH=${pkgs.curl}/bin:${pkgs.coreutils}/bin
+ '';
+ };
};
systemd.user.timers.syncical = {