summaryrefslogtreecommitdiff
path: root/home/home.nix
diff options
context:
space:
mode:
authorstuebinm2022-02-06 00:57:28 +0100
committerstuebinm2022-02-06 00:57:28 +0100
commit9b95af234821bad0834f4990c35dcbed61112357 (patch)
tree5d851b0900fcaafb09b69150691a150151ec5a92 /home/home.nix
parente6718bd6298af2f6d540d97ab184fab5ab4d164b (diff)
home: fix syncical
turns out systemd user services just don't inherit any PATH at all??
Diffstat (limited to 'home/home.nix')
-rw-r--r--home/home.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/home/home.nix b/home/home.nix
index 1846e12..d48c162 100644
--- a/home/home.nix
+++ b/home/home.nix
@@ -108,7 +108,13 @@
systemd.user.services.syncical = let
feeds = (import inputs.feeds).ical; in {
Unit.Description = "syncs ical feeds for almanac agenda";
- Service.ExecStart = "${./scripts/sync.scm} ${lib.fold (a: b: a + " " + b) "" feeds}";
+ Service = {
+ ExecStart = "${pkgs.gauche}/bin/gosh ${./scripts/sync.scm} ${lib.fold (a: b: a + " " + b) "" feeds}";
+ X-ReloadIfChanged = true;
+ Environment = ''
+ PATH=${pkgs.curl}/bin:${pkgs.coreutils}/bin
+ '';
+ };
};
systemd.user.timers.syncical = {