aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 81a639e..76afb54 100644
--- a/flake.nix
+++ b/flake.nix
@@ -34,6 +34,18 @@
program = "${self.defaultPackage."${system}"}/bin/deploy";
};
+ devShell = let
+ inherit (self.packages.${system}) deploy-rs;
+ in
+ pkgs.mkShell {
+ inherit (deploy-rs)
+ nativeBuildInputs
+ builtDependencies;
+
+ buildInputs = deploy-rs.buildInputs
+ ++ [ pkgs.nixUnstable ];
+ };
+
lib = rec {
setActivate = base: activate: pkgs.buildEnv {
name = ("activatable-" + base.name);