aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorChristian Höppner2020-11-14 20:37:51 +0000
committernotgne22020-11-14 14:12:29 -0700
commitf32a6f17f6b1fb4bf9c3a9857e459177081dbb56 (patch)
treeb3032c1b29a00e76b7c5c56b358d9c52e13b8fdf /flake.nix
parentcd751f1e95c9ac5e73cf5e6b0423d05ec9adcc7f (diff)
[OPS-1085] Add CI
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 81a639e..76afb54 100644
--- a/flake.nix
+++ b/flake.nix
@@ -34,6 +34,18 @@
program = "${self.defaultPackage."${system}"}/bin/deploy";
};
+ devShell = let
+ inherit (self.packages.${system}) deploy-rs;
+ in
+ pkgs.mkShell {
+ inherit (deploy-rs)
+ nativeBuildInputs
+ builtDependencies;
+
+ buildInputs = deploy-rs.buildInputs
+ ++ [ pkgs.nixUnstable ];
+ };
+
lib = rec {
setActivate = base: activate: pkgs.buildEnv {
name = ("activatable-" + base.name);