aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 1 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index 76afb54..402d63f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -63,11 +63,7 @@
];
};
- checkSchema = builtins.trace "WARNING: deploy-rs#checkSchema is deprecated" checks.schema;
-
- deployChecks = deploy: builtins.mapAttrs (_: check: check deploy) checks;
-
- checks = {
+ deployChecks = deploy: builtins.mapAttrs (_: check: check deploy) {
schema = deploy: pkgs.runCommandNoCC "jsonschema-deploy-system" { } ''
${pkgs.python3.pkgs.jsonschema}/bin/jsonschema -i ${pkgs.writeText "deploy.json" (builtins.toJSON deploy)} ${./interface.json} && touch $out
'';