aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authornotgne22020-11-14 19:46:19 -0700
committernotgne22020-11-14 20:05:50 -0700
commit9a9d9b5c3ea13b212d7d297c1243f4836583d164 (patch)
treefa459cecab853da696664a2d50359358bbc55fab /flake.nix
parentc15470560e615457c54af9f82ccfd4f9c4a40d01 (diff)
Remove deprecated `checkSchema`
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 1 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index 76afb54..402d63f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -63,11 +63,7 @@
];
};
- checkSchema = builtins.trace "WARNING: deploy-rs#checkSchema is deprecated" checks.schema;
-
- deployChecks = deploy: builtins.mapAttrs (_: check: check deploy) checks;
-
- checks = {
+ deployChecks = deploy: builtins.mapAttrs (_: check: check deploy) {
schema = deploy: pkgs.runCommandNoCC "jsonschema-deploy-system" { } ''
${pkgs.python3.pkgs.jsonschema}/bin/jsonschema -i ${pkgs.writeText "deploy.json" (builtins.toJSON deploy)} ${./interface.json} && touch $out
'';