aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 40f0724..03f4a25 100644
--- a/flake.nix
+++ b/flake.nix
@@ -143,7 +143,17 @@
devShell = pkgs.mkShell {
inputsFrom = [ self.packages.${system}.deploy-rs ];
- buildInputs = [ pkgs.nixUnstable pkgs.rust-analyzer pkgs.rustfmt ];
+ RUST_SRC_PATH = "${pkgs.rust.packages.stable.rustPlatform.rustLibSrc}";
+ buildInputs = with pkgs; [
+ nixUnstable
+ cargo
+ rustc
+ rust-analyzer
+ rustfmt
+ clippy
+ reuse
+ rust.packages.stable.rustPlatform.rustLibSrc
+ ];
};
checks = {