aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authornotgne22021-08-04 00:02:58 -0700
committernotgne22021-08-04 00:06:51 -0700
commit63ccbd7cddcbd80d1c7e819dc42db15f7692ea71 (patch)
treeb77a42aa5d1670c9e3e6ef77e42e547b3827179e /flake.nix
parent587cbcfe8d3ea05c5bb153764d3617012ef28c86 (diff)
Add .envrc and fix devShell to work with more tools
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 40f0724..03f4a25 100644
--- a/flake.nix
+++ b/flake.nix
@@ -143,7 +143,17 @@
devShell = pkgs.mkShell {
inputsFrom = [ self.packages.${system}.deploy-rs ];
- buildInputs = [ pkgs.nixUnstable pkgs.rust-analyzer pkgs.rustfmt ];
+ RUST_SRC_PATH = "${pkgs.rust.packages.stable.rustPlatform.rustLibSrc}";
+ buildInputs = with pkgs; [
+ nixUnstable
+ cargo
+ rustc
+ rust-analyzer
+ rustfmt
+ clippy
+ reuse
+ rust.packages.stable.rustPlatform.rustLibSrc
+ ];
};
checks = {