diff options
author | Andreas Fuchs | 2020-12-13 20:48:38 -0500 |
---|---|---|
committer | notgne2 | 2020-12-15 13:00:01 -0700 |
commit | 3bcb3879bddefed916f416b6a9fa406ff58f4ec7 (patch) | |
tree | 77cc0caeac28cb93c7253c4e57faea645c692d29 /Cargo.toml | |
parent | ba7f57086c41e5094f880e9bb7a117861bb4df5a (diff) |
Update tokio & pull in notify, instead of inotify
The notify crate is cross-platform, and the newer tokio has some bug
fixes. Let's use those.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -12,7 +12,7 @@ edition = "2018" [dependencies] clap = "3.0.0-beta.2" -tokio = { version = "0.2.22", features = [ "full" ] } +tokio = { version = "0.3.5", features = [ "full" ] } serde_json = "1.0.48" serde_derive = "1.0.104" serde = "1.0.104" @@ -20,7 +20,7 @@ merge = "0.1.0" whoami = "0.9.0" log = "0.4" pretty_env_logger = "0.4" -inotify = "0.8" +notify = "5.0.0-pre.3" futures-util = "0.3.6" fork = "0.1" thiserror = "1.0" |