aboutsummaryrefslogtreecommitdiff
path: root/wapkgs.nix
diff options
context:
space:
mode:
authorstuebinm2021-03-10 22:15:46 +0100
committerstuebinm2021-03-10 22:15:46 +0100
commit2cc766a3ce7daeac1088c3233ff7d37813aec0cb (patch)
tree1fe08b97deb2d8543c7a2cd809701ec947422185 /wapkgs.nix
parent5d61d1bcb2fe11a3ff469a4f3a1be1885218472d (diff)
mark hasi pkgs as broken
Apparently there's an inconsistent yarn lock file in their front module currently, so I'll just mark it as broken for now.
Diffstat (limited to 'wapkgs.nix')
-rw-r--r--wapkgs.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/wapkgs.nix b/wapkgs.nix
index 86e9866..5bb3278 100644
--- a/wapkgs.nix
+++ b/wapkgs.nix
@@ -9,8 +9,8 @@ let
};
hasi = pkgs.fetchgit {
url = "https://gitlab.hasi.it/herzi/project/workadventure";
- rev = "2f21c732eac0c1741dca6a70a92445e4792202c0";
- sha256 = "0463hjm7d1b87my58abys60a2x1882mpd7rxsfgd5spspdgqx0xc";
+ rev = "c7303a458d8de3d3aa095738987d089e62684a1a";
+ sha256 = "0gbax61jd6bdhql94mfyqabih20y9an042c5bixqkpk0rzv0c95l";
};
tabascoeye = pkgs.fetchFromGitHub {
owner = "tabascoeye";
@@ -41,7 +41,7 @@ let
workadventure-tabascoeye = mkWorkadventureset workadventure-tabascoeye tabascoeye "tabascoeye";
});
in {
- workadventure-hasi = wapkgs.workadventure-hasi;
+ workadventure-hasi = pkgs.lib.mapAttrs (name: pkg: pkg.overrideAttrs(old: { meta.broken = true; })) wapkgs.workadventure-hasi;
workadventure-tcm = wapkgs.workadventure-tcm;
workadventure-tabascoeye = wapkgs.workadventure-tabascoeye;
}