aboutsummaryrefslogtreecommitdiff
path: root/test.nix
diff options
context:
space:
mode:
authorstuebinm2021-02-25 17:05:32 +0100
committerstuebinm2021-02-25 17:05:32 +0100
commit86799d84ff58fd43488dcdd5b75d5a07c12ed973 (patch)
tree2798dfc268f69c57dc109ecf9a56b9f1cd8fcad8 /test.nix
parentbfae9d9bfa90a0189d943ca865fa046f510b9922 (diff)
parent90720751b638df1897a97942f50d3d30b6803c46 (diff)
Merge branch 'master' of https://gitlab.com/fediventure/workadventure-nix
Diffstat (limited to 'test.nix')
-rw-r--r--test.nix21
1 files changed, 7 insertions, 14 deletions
diff --git a/test.nix b/test.nix
index 3df16d6..c4d2f56 100644
--- a/test.nix
+++ b/test.nix
@@ -1,16 +1,9 @@
-# NOTE: this file is only meant to be used for quickly building a
-# version of workadventure, not for actual use. Use callPackages on
-# the subdirectories directly for use e.g. in modules.
-with import <nixpkgs> {};
+{ system ? builtins.currentSystem, nixpkgs ? <nixpkgs> }:
-lib.fix (self: let
- callPackage = lib.callPackageWith self;
-in pkgs // {
- workadventure-back = callPackage ./back {};
- workadventure-pusher = callPackage ./pusher {};
- workadventure-messages = callPackage ./messages {};
- workadventure-front = callPackage ./front {};
- workadventure-uploader = callPackage ./uploader {};
- workadventure-maps = callPackage ./maps {};
-})
+let
+ pkgs = import nixpkgs { inherit system; overlays = [ (import ./overlay.nix) ]; };
+in {
+ inherit pkgs;
+ inherit (pkgs) workadventure;
+}