aboutsummaryrefslogtreecommitdiff
path: root/instance-options.nix
diff options
context:
space:
mode:
authorstuebinm2021-03-09 15:38:16 +0100
committerstuebinm2021-03-09 15:38:16 +0100
commit6908ecac521c0ddf3d8af75adefa7209f7a8719c (patch)
tree62714c31f3c0cef23d56d82f05682fbf729dcec6 /instance-options.nix
parentead8c570b6dfd00531bf7ada77e08bbd9955b731 (diff)
Added hasi workadventure version
wapkgs.nix new contains packages for several different versions of workadventure (so far hasi + thecodingmachine), which can both be used. Unfortunately, this appears to require some weird hacks to convince nix to sort out the dependencies without having to actually duplicate all the packaging code, but it works.
Diffstat (limited to 'instance-options.nix')
-rw-r--r--instance-options.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/instance-options.nix b/instance-options.nix
index c95a506..6c3d6f2 100644
--- a/instance-options.nix
+++ b/instance-options.nix
@@ -26,7 +26,7 @@ with pkgs;
};
package = mkOption {
- default = workadventure.back;
+ default = workadventure-tcm.back;
defaultText = "third_party.workadventure-nix.back";
type = types.package;
description = "Backend package to use";
@@ -46,7 +46,7 @@ with pkgs;
};
package = mkOption {
- default = workadventure.pusher;
+ default = workadventure-tcm.pusher;
defaultText = "third_party.workadventure-nix.pusher";
type = types.package;
description = "Pusher package to use";
@@ -55,7 +55,7 @@ with pkgs;
frontend = {
package = mkOption {
- default = workadventure.front;
+ default = workadventure-tcm.front;
defaultText = "third_party.workadventure-nix.front";
type = types.package;
description = "Front package to use";
@@ -237,7 +237,7 @@ with pkgs;
description = "Whether to serve maps through nginx.";
};
path = mkOption {
- default = workadventure.maps.outPath + "/workadventuremaps/";
+ default = workadventure-tcm.maps.outPath + "/workadventuremaps/";
defaultText = "third_party.workadventure-nix.maps";
type = types.path;
description = "Maps package to use";