summaryrefslogtreecommitdiff
path: root/walint-cli/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'walint-cli/default.nix')
-rw-r--r--walint-cli/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/walint-cli/default.nix b/walint-cli/default.nix
new file mode 100644
index 0000000..938bc4f
--- /dev/null
+++ b/walint-cli/default.nix
@@ -0,0 +1,18 @@
+{ mkDerivation, aeson, aeson-pretty, base, bytestring
+, getopt-generics, lib, process, template-haskell, text, universum
+, walint
+}:
+mkDerivation {
+ pname = "walint-cli";
+ version = "0.1";
+ src = ./.;
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson aeson-pretty base bytestring getopt-generics process
+ template-haskell text universum walint
+ ];
+ homepage = "https://stuebinm.eu/git/walint";
+ license = "unknown";
+ mainProgram = "walint";
+}