summaryrefslogtreecommitdiff
path: root/fixed.nix
diff options
context:
space:
mode:
authorstuebinm2022-10-11 11:28:30 +0200
committerstuebinm2022-10-11 11:28:30 +0200
commita29be8315c2e6647a5878529affda84ec8036ccb (patch)
tree9e5973c8e4a149dfcf2b20fcff6c08fe8c90fe59 /fixed.nix
parentb6bc6c59c003cfbcfad2d5b1cf8809476f60fa17 (diff)
update stack resolver
(also got rid of the map templater, which had version problems with mustache — it's not likely anyone will need it anyways)
Diffstat (limited to 'fixed.nix')
-rw-r--r--fixed.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/fixed.nix b/fixed.nix
deleted file mode 100644
index 35c2ba9..0000000
--- a/fixed.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ nixpkgs ? import <nixpkgs> {} }:
-with nixpkgs;
-
-stdenv.mkDerivation {
- name = "walint-fixed";
-
- buildInputs = [ ghc stack zlib zlib.dev git openssl cacert ];
-
- src = ./.;
-
- buildPhase = ''
- cp -r $src .
- mkdir /tmp/stack-home
- HOME=/tmp/stack-home stack build --no-nix --system-ghc
- '';
-
- installPhase = ''
- HOME=/tmp/stack-home stack install --local-bin-path $out --no-nix --system-ghc
- mkdir -p $out/share/walint
- cp -r static $out/share/walint
- cp config.json $out/share/walint
- cp config.toml $out/share/walint
- '';
-
- outputHashAlgo = "sha256";
- outputHashMode = "recursive";
- # replace this with the correct SHA256
- outputHash = "sha256-Qd7MDGslrS6zs6WWI9sjzDous0nUbrjdK2fF747KLq8=";
- dontShrink = true;
-}