summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorstuebinm2021-10-01 00:26:10 +0200
committerstuebinm2021-10-01 00:26:10 +0200
commitfafc59bfac01da3f080dcda9d2e01572629e4306 (patch)
treefca0944ddc691ba1b09be0fb4998e9e0402f60b8 /default.nix
parentf141d99d8fa367d0151a0896613fed76c66bfab8 (diff)
add default.nix
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..541c913
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,21 @@
+{ mkDerivation, aeson, aeson-pretty, base, bytestring
+, bytestring-encoding, containers, either, extra, filepath
+, getopt-generics, lib, mtl, regex-tdfa, text, transformers, vector
+}:
+mkDerivation {
+ pname = "walint";
+ version = "0.1.0.0";
+ src = ./.;
+ isLibrary = true;
+ isExecutable = true;
+ libraryHaskellDepends = [
+ aeson base bytestring containers either extra filepath
+ getopt-generics mtl regex-tdfa text transformers vector
+ ];
+ executableHaskellDepends = [
+ aeson aeson-pretty base bytestring bytestring-encoding
+ getopt-generics text
+ ];
+ license = "unknown";
+ hydraPlatforms = lib.platforms.none;
+}