aboutsummaryrefslogtreecommitdiff
path: root/example.nix
diff options
context:
space:
mode:
Diffstat (limited to 'example.nix')
-rw-r--r--example.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/example.nix b/example.nix
new file mode 100644
index 0000000..249ae4a
--- /dev/null
+++ b/example.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+
+{
+ imports = [ ./module.nix ];
+
+ services.uplcg = {
+ enable = true;
+ port = 8080;
+ domain = "0.0.0.0";
+ # cards = {
+ # generic = {
+ # enabled = true;
+ # black = [
+ # "_ and white _"
+ # ];
+ # white = [
+ # "blue"
+ # "green"
+ # ];
+ # };
+ # };
+ };
+
+ networking.firewall.allowedTCPPorts = [ 8080 ];
+}