summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..cac6b57
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,21 @@
+{
+ description = "A very basic flake";
+
+ inputs = {
+ rust-overlay = {
+ url = "github:oxalica/rust-overlay";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
+ nixpkgs.url = "nixpkgs/nixos-unstable";
+ };
+ outputs = { self, nixpkgs, rust-overlay, ... }: let
+ system = "x86_64-linux";
+ overlays = [ rust-overlay.overlays.default ];
+ pkgs = import nixpkgs { inherit overlays system; };
+ rust = pkgs.rust-bin.fromRustupToolchainFile ./rust-toolchain.toml;
+ buildRustPackage = pkgs.rustPlatform.buildRustPackage;
+ in {
+ packages.x86_64-linux.wage =
+ pkgs.callPackage ./wage { inherit rust buildRustPackage; };
+ };
+}