aboutsummaryrefslogtreecommitdiff
path: root/picarones-hs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'picarones-hs/default.nix')
-rw-r--r--picarones-hs/default.nix48
1 files changed, 15 insertions, 33 deletions
diff --git a/picarones-hs/default.nix b/picarones-hs/default.nix
index ebcb880..c61d763 100644
--- a/picarones-hs/default.nix
+++ b/picarones-hs/default.nix
@@ -1,33 +1,15 @@
-{ nixpkgs ? import <nixpkgs> {}, compiler ? "default", doBenchmark ? false }:
-
-let
-
- inherit (nixpkgs) pkgs;
-
- f = { mkDerivation, aeson, base, bytestring, stdenv, text
- , unordered-containers, websockets
- }:
- mkDerivation {
- pname = "haskell-ws-test";
- version = "0.1.0.0";
- src = ./.;
- isLibrary = false;
- isExecutable = true;
- executableHaskellDepends = [
- aeson base bytestring text unordered-containers websockets
- ];
- license = "unknown";
- hydraPlatforms = stdenv.lib.platforms.none;
- };
-
- haskellPackages = if compiler == "default"
- then pkgs.haskellPackages
- else pkgs.haskell.packages.${compiler};
-
- variant = if doBenchmark then pkgs.haskell.lib.doBenchmark else pkgs.lib.id;
-
- drv = variant (haskellPackages.callPackage f {});
-
-in
-
- if pkgs.lib.inNixShell then drv.env else drv
+{ mkDerivation, aeson, base, bytestring, stdenv, text
+, unordered-containers, websockets
+}:
+mkDerivation {
+ pname = "picarones-hs";
+ version = "0.1.0.0";
+ src = ./.;
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson base bytestring text unordered-containers websockets
+ ];
+ license = "unknown";
+ hydraPlatforms = stdenv.lib.platforms.none;
+}