aboutsummaryrefslogtreecommitdiff
path: root/example.nix
diff options
context:
space:
mode:
authorstuebinm2021-03-07 23:52:19 +0100
committerstuebinm2021-03-07 23:52:19 +0100
commit92c1ef1af95740077282d773242fdd1820c8d15b (patch)
treee8b6feb39975f4b1126eb49f2c7564e2cf3dae34 /example.nix
parent09eeb58abb279e1049493460a7a99124aa4d9a78 (diff)
Added basic nixos module (and restructured some files)
Right now, this is capable of setting up a running instance of picarones in a couple lines of config (both backend server and the webapp, using nginx). More options should still be added, especially to make the backend's port configurable (but this requires adding features to the haskell code)
Diffstat (limited to 'example.nix')
-rw-r--r--example.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/example.nix b/example.nix
new file mode 100644
index 0000000..4c66bc9
--- /dev/null
+++ b/example.nix
@@ -0,0 +1,15 @@
+{config, pkgs, ...}:
+
+{
+ imports = [ ./default.nix ];
+
+ services.picarones = {
+ enable = true;
+ frontend = {
+ enable = true;
+ domain = "10.233.4.2";
+ };
+ };
+
+ networking.firewall.allowedTCPPorts = [ 80 ];
+}