summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..f8dcee1
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "ntfy-matrix-bot"
+version = "0.1.0"
+edition = "2021"
+authors = [ "terru <stuebinm@disroot.org" ]
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+tokio = { version = "1.24", features = ["macros", "rt-multi-thread"] }
+anyhow = "1"
+tracing-subscriber = "0.3"
+matrix-sdk = { version = "0.7", features = ["rustls-tls","automatic-room-key-forwarding","e2e-encryption"], default-features = false }
+tracing = "0.1"
+reqwest = { version = "0.11", features = ["rustls-tls", "rustls-tls-native-roots", "stream"], default-features = false }
+tokio-util = "0.7.10"
+futures-util = "0.3.30"
+serde_json = "1.0.115"
+serde = { version = "1.0.197", features = ["derive"] }
+confique = { version = "0.2", default-features = false, features = [ "toml" ] }
+secrecy = { version = "0.8", features = [ "serde" ] }
+clap = { version = "4.5", features = [ "cargo", "help", "std" ], default-features = false }