summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorstuebinm2024-04-03 22:22:38 +0200
committerstuebinm2024-04-03 23:36:33 +0200
commit0567f916d4365c8dc0be99d194fe6d157befbc81 (patch)
tree8e1123ae8112abab0f3726da75bec2c08787ce0e /Cargo.toml
parent48534f8c321cb33190a3cc80a9c364ffbf68c878 (diff)
very basic query language
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 7 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7c3c8d6..4705207 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,10 +8,12 @@ authors = [ "stuebinm <stuebinm@disroot.org>" ]
[dependencies]
rnix = "0.11"
-anyhow = "1.0.57"
+anyhow = "1.0"
regex = "1.6"
-threadpool = "1.8.1"
-rowan = "0.15.15"
-serde_json = "1.0.114"
-serde = { version = "1.0.197", features = ["derive"] }
+threadpool = "1.8"
+rowan = "0.15"
+serde_json = "1.0"
+serde = { version = "1.0", features = ["derive"] }
itertools = "0.12.1"
+m_lexer = "0.0.4"
+clap = { version = "4.5", features = [ "cargo", "help", "std" ], default-features = false }