summaryrefslogtreecommitdiff
path: root/surltesh-echer/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'surltesh-echer/hardware-configuration.nix')
-rw-r--r--surltesh-echer/hardware-configuration.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/surltesh-echer/hardware-configuration.nix b/surltesh-echer/hardware-configuration.nix
new file mode 100644
index 0000000..4cfe83b
--- /dev/null
+++ b/surltesh-echer/hardware-configuration.nix
@@ -0,0 +1,26 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ehci_pci" "ahci" "usb_storage" "sd_mod" "sdhci_pci" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/9cc0a379-0671-4f2e-86ef-9f38f3db3b41";
+ fsType = "ext4";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-uuid/7d644f80-1042-4a9f-ace0-620b6a1c916f"; }
+ ];
+
+ powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}