summaryrefslogtreecommitdiff
path: root/surltesh-echer/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'surltesh-echer/configuration.nix')
-rw-r--r--surltesh-echer/configuration.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/surltesh-echer/configuration.nix b/surltesh-echer/configuration.nix
new file mode 100644
index 0000000..d3ab32d
--- /dev/null
+++ b/surltesh-echer/configuration.nix
@@ -0,0 +1,39 @@
+{ config, pkgs, ... }:
+
+{
+ imports =
+ [
+ ./hardware-configuration.nix
+ ];
+
+ # Use the GRUB 2 boot loader.
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+ boot.loader.grub.device = "/dev/sda";
+
+ networking.hostName = "surltesh-echer"; # Define your hostname.
+ # networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
+
+ # Set your time zone.
+ time.timeZone = "Europe/Amsterdam";
+
+ networking = {
+ networkmanager.enable = true;
+ useDHCP = false;
+ interfaces = {
+ enp0s25.useDHCP = true;
+ wlp3s0.useDHCP = true;
+ wwp0s20u4i6.useDHCP = true;
+ };
+ };
+
+ # This value determines the NixOS release from which the default
+ # settings for stateful data, like file locations and database versions
+ # on your system were taken. It‘s perfectly fine and recommended to leave
+ # this value at the release version of the first install of this system.
+ # Before changing this value read the documentation for this option
+ # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+ system.stateVersion = "20.09"; # Did you read the comment?
+
+}
+