summaryrefslogtreecommitdiff
path: root/pkgs/typst.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/typst.nix')
-rw-r--r--pkgs/typst.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/pkgs/typst.nix b/pkgs/typst.nix
new file mode 100644
index 0000000..0290899
--- /dev/null
+++ b/pkgs/typst.nix
@@ -0,0 +1,18 @@
+{ craneLib, fetchFromGitHub, lib, git }:
+
+craneLib.buildPackage rec {
+ pname = "typst-cli";
+ version = "22-03-21-2";
+
+ cargoExtraArgs = "-p typst-cli";
+ src = fetchFromGitHub {
+ owner = "typst";
+ repo = "typst";
+ sha256 = "sha256-JvVuTOnonHWDkT2MSQUVUuL23dS7fRDzQhqLpHE9pZw=";
+ rev = version;
+ leaveDotGit = true;
+ };
+
+ # the build.rs script wants a version hash from git.
+ buildInputs = [ git ];
+}