summaryrefslogtreecommitdiff
path: root/pkgs/overlay.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/overlay.nix')
-rw-r--r--pkgs/overlay.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/pkgs/overlay.nix b/pkgs/overlay.nix
index 09ca9ee..ebea1a0 100644
--- a/pkgs/overlay.nix
+++ b/pkgs/overlay.nix
@@ -102,4 +102,22 @@ in
mu = oldstable.mu;
matrix-to = self.callPackage ./matrix-to.nix {};
+
+ lean4 = unstable.lean4.overrideAttrs (old: rec {
+ version = "4.1.0-rc1";
+ src = self.fetchFromGitHub {
+ owner = "leanprover";
+ repo = "lean4";
+ rev = "v${version}";
+ hash = "sha256-OQ72uweFMSkOzJ9u92enNql48ReZ+NBlnXtnanH+ZVA=";
+ };
+ postPatch = ''
+ substituteInPlace src/CMakeLists.txt \
+ --replace 'set(GIT_SHA1 "")' 'set(GIT_SHA1 "${src.rev}")'
+
+ # Remove tests that fails in sandbox.
+ # It expects `sourceRoot` to be a git repository.
+ rm -rf src/lake/examples/git/
+ '';
+ });
}