summaryrefslogtreecommitdiff
path: root/pkgs/overlay.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/overlay.nix')
-rw-r--r--pkgs/overlay.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/pkgs/overlay.nix b/pkgs/overlay.nix
index 671a7c2..6e654b3 100644
--- a/pkgs/overlay.nix
+++ b/pkgs/overlay.nix
@@ -134,6 +134,18 @@ in
#### packaged mostly as shitpost / to play around with ####
+ bookwyrm = (self.callPackage ./bookwyrm.nix {
+ python = super.python311.override ({
+ packageOverrides = self: super: {
+ django = super.django_3;
+ python-crontab = super.python-crontab.overridePythonAttrs (_: { doCheck = false; });
+ django-sass-processor = self.callPackage ./python/django-sass-processor.nix {};
+ django-imagekit = self.callPackage ./python/django-imagekit.nix {};
+ bw-file-resubmit = self.callPackage ./python/bw-file-resubmit.nix {};
+ };
+ });
+ });
+
glitchtip = (self.callPackage ./glitchtip.nix {
python = super.python310.override ({
packageOverrides = self: super: {