summaryrefslogtreecommitdiff
path: root/pkgs/overlay.nix
diff options
context:
space:
mode:
authorstuebinm2024-02-11 17:14:24 +0100
committerstuebinm2024-02-11 17:14:24 +0100
commit074a6ffb981a7c97876dcb93e0d5c2113a9bd74c (patch)
tree69880436b140b675009434cd5101a5711f18528a /pkgs/overlay.nix
parent062d966cb4790437dbd5050c3fb84925a0fa3a96 (diff)
pkgs: init bookwyrm
this is still missing: - a nice way to do settings - lots of testing (run the manage.py test script in a nixos test?) - an actual way to deploy this in a halfway reasonable way
Diffstat (limited to 'pkgs/overlay.nix')
-rw-r--r--pkgs/overlay.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/pkgs/overlay.nix b/pkgs/overlay.nix
index 671a7c2..6e654b3 100644
--- a/pkgs/overlay.nix
+++ b/pkgs/overlay.nix
@@ -134,6 +134,18 @@ in
#### packaged mostly as shitpost / to play around with ####
+ bookwyrm = (self.callPackage ./bookwyrm.nix {
+ python = super.python311.override ({
+ packageOverrides = self: super: {
+ django = super.django_3;
+ python-crontab = super.python-crontab.overridePythonAttrs (_: { doCheck = false; });
+ django-sass-processor = self.callPackage ./python/django-sass-processor.nix {};
+ django-imagekit = self.callPackage ./python/django-imagekit.nix {};
+ bw-file-resubmit = self.callPackage ./python/bw-file-resubmit.nix {};
+ };
+ });
+ });
+
glitchtip = (self.callPackage ./glitchtip.nix {
python = super.python310.override ({
packageOverrides = self: super: {