summaryrefslogtreecommitdiff
path: root/pkgs/glitchtip.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/glitchtip.nix')
-rw-r--r--pkgs/glitchtip.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/pkgs/glitchtip.nix b/pkgs/glitchtip.nix
index fa1a594..380eb48 100644
--- a/pkgs/glitchtip.nix
+++ b/pkgs/glitchtip.nix
@@ -17,7 +17,10 @@ let
inherit python;
projectDir = src;
- patches = [ ./0001-fix-poetry-name-issue.patch ];
+ patches = [
+ ./0001-fix-poetry-name-issue.patch
+ ./0002-fix-django-version-bound.patch
+ ];
# a bunch of python packages seem to misdeclare their dependencies
# a few are also just broken when building with Nix, so use these
@@ -66,6 +69,7 @@ let
buildInputs = [ unzip ];
propagatedBuildInputs = [ pythonApp.dependencyEnv ];
+
buildPhase = ''
unzip ${frontend} -d unpacked
mv unpacked/dist/glitchtip-frontend dist