summaryrefslogtreecommitdiff
path: root/modules/mollysocket.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/mollysocket.nix')
-rw-r--r--modules/mollysocket.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/modules/mollysocket.nix b/modules/mollysocket.nix
index 5ca68c9..a318124 100644
--- a/modules/mollysocket.nix
+++ b/modules/mollysocket.nix
@@ -6,6 +6,8 @@ let
configFile = configFormat.generate "mollysocket-config.toml" cfg.settings;
in
{
+ disabledModules = [ "services/misc/mollysocket.nix" ];
+
options.services.mollysocket = with lib; {
enable = mkEnableOption
"mollysocket, which allows getting Signal notifications via UnifiedPush";
@@ -13,7 +15,7 @@ in
settings = mkOption {
default = {};
type = with types; attrsOf (oneOf [ str int bool (listOf str) ]);
- description = lib.mdDoc ''
+ description = ''
Configuration options for mollysocket. See the upstream
[Readme.md](https://github.com/mollyim/mollysocket/blob/main/README.md#configuration)
file for what is permissable here.
@@ -28,7 +30,7 @@ in
environmentFile = mkOption {
default = null;
type = with types; nullOr path;
- description = lib.mdDoc ''
+ description = ''
Configuration options set via environment Variables. Useful for e.g.
keeping some values outside of Nix.
'';
@@ -37,7 +39,7 @@ in
stateDir = mkOption {
default = "/var/lib/mollysocket";
type = lib.types.path;
- description = lib.mdDoc ''
+ description = ''
Directory in which state is kept, unless a custom database location is
set using {option}`services.mollysocket.settings.db`. This directory
will be created automatically.
@@ -47,7 +49,7 @@ in
installWrapper = mkOption {
default = true;
type = lib.types.bool;
- description = lib.mdDoc ''
+ description = ''
Whether to install a mollysocket executable wrapped to use the generated
config into {option}`environment.systemPackages`.
'';