summaryrefslogtreecommitdiff
path: root/lib/deploy.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/deploy.nix')
-rw-r--r--lib/deploy.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/lib/deploy.nix b/lib/deploy.nix
new file mode 100644
index 0000000..1b8d1f2
--- /dev/null
+++ b/lib/deploy.nix
@@ -0,0 +1,23 @@
+{ pkgs, hosts, groups }:
+
+with pkgs.lib;
+
+(
+ mapAttrs (name: hosts: pkgs.writeScript "deploy-group-${name}" ''
+ #!${pkgs.runtimeShell}
+ export PATH=
+ ${concatMapStrings (host: ''
+ echo "deploying ${host.config.networking.hostName}..."
+ ${host.config.system.build.deployScript} $1 &
+ PID_LIST+=" $!"
+ '') hosts}
+ # FIXME: remove jobs from PIDLIST once they finish
+ trap "kill $PID_LIST" SIGINT
+ wait $PID_LIST
+ '') groups
+) // (
+ mapAttrs
+ (name: host: host.config.system.build.deployScript)
+ (filterAttrs (_: host: host.config.hexchen.deploy.enable) hosts)
+)
+