summaryrefslogtreecommitdiff
path: root/inputs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'inputs.nix')
-rw-r--r--inputs.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/inputs.nix b/inputs.nix
index 8902303..7329531 100644
--- a/inputs.nix
+++ b/inputs.nix
@@ -34,6 +34,16 @@ let
];
} // { outPath = sources.nixpkgs.outPath; };
+ # 'boring' version of nixpkgs with fewer (used for vm tests,
+ # so they're buildable without having to compile e.g. the lix version
+ # from the overlay)
+ nixpkgs-boring = import sources.nixpkgs {
+ inherit system;
+ overlays = [
+ (import ./pkgs/overlay.nix { inherit inputs; })
+ ];
+ } // { outPath = sources.nixpkgs.outPath; };
+
nixpkgs-unstable =
import sources.nixpkgs-unstable { inherit system; }
// { outPath = sources.nixpkgs-unstable.outPath; };