diff options
author | stuebinm | 2025-05-04 19:09:44 +0200 |
---|---|---|
committer | stuebinm | 2025-05-04 19:15:01 +0200 |
commit | 2e23053c8ef76416553973cc227ac976a9765128 (patch) | |
tree | 7afcbe4f151f02279d542fb9b4d076e3a63e6804 /inputs.nix | |
parent | 2ebb1305c8bd4ae069c5053ac8e33f19b43e9b09 (diff) |
tests: use nixpkgs without unnecessary overlays
introduces a 'boring' nixpkgs used by default for running VM tests
in this repo, i.e. do not force others to build my current version
of things like lix, which I overlay & which are part of any system
closure, but not actually important for testing.
Diffstat (limited to 'inputs.nix')
-rw-r--r-- | inputs.nix | 10 |
1 files changed, 10 insertions, 0 deletions
@@ -34,6 +34,16 @@ let ]; } // { outPath = sources.nixpkgs.outPath; }; + # 'boring' version of nixpkgs with fewer (used for vm tests, + # so they're buildable without having to compile e.g. the lix version + # from the overlay) + nixpkgs-boring = import sources.nixpkgs { + inherit system; + overlays = [ + (import ./pkgs/overlay.nix { inherit inputs; }) + ]; + } // { outPath = sources.nixpkgs.outPath; }; + nixpkgs-unstable = import sources.nixpkgs-unstable { inherit system; } // { outPath = sources.nixpkgs-unstable.outPath; }; |