summaryrefslogtreecommitdiff
path: root/ilex/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ilex/configuration.nix')
-rw-r--r--ilex/configuration.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/ilex/configuration.nix b/ilex/configuration.nix
index 9486547..866b1e3 100644
--- a/ilex/configuration.nix
+++ b/ilex/configuration.nix
@@ -28,5 +28,28 @@
system.stateVersion = "22.11";
+
+ services.tlp = {
+ enable = true;
+ settings = {
+ START_CHARGE_THRESH_BAT0 = 75;
+ STOP_CHARGE_THRESH_BAT0 = 80;
+ PLATFORM_PROFILE_ON_AC = "performance";
+ PLATFORM_PROFILE_ON_BAT = "low-power";
+ CPU_SCALING_GOVERNOR_ON_AC = "performance";
+ CPU_SCALING_GOVERNOR_ON_BAT = "schedutil";
+ DEVICES_TO_ENABLE_ON_STARTUP = "wifi";
+ DEVICES_TO_DISABLE_ON_STARTUP = "bluetooth wwan";
+ DEVICES_TO_DISABLE_ON_LAN_CONNECT = "wifi";
+ DEVICES_TO_ENABLE_ON_LAN_DISCONNECT = "wifi";
+ WIFI_PWR_ON_AC = "off";
+ WIFI_PWR_ON_BAT = "on";
+ USB_AUTOSUSPEND = 1;
+ USB_EXCLUDE_AUDIO = 1;
+ };
+ };
+
+
+
}