summaryrefslogtreecommitdiff
path: root/ilex/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ilex/configuration.nix')
-rw-r--r--ilex/configuration.nix20
1 files changed, 8 insertions, 12 deletions
diff --git a/ilex/configuration.nix b/ilex/configuration.nix
index 2b07092..ec1f856 100644
--- a/ilex/configuration.nix
+++ b/ilex/configuration.nix
@@ -7,6 +7,7 @@
{
imports = [
./hardware-configuration.nix
+ ../modules/glitchtip.nix
];
networking.firewall.allowedTCPPorts = [ 5000 ];
@@ -52,22 +53,17 @@
'';
};
- services.uwsgi = {
+ services.glitchtip = {
enable = true;
- plugins = [ "python3" ];
- instance = {
- type = "normal";
- pythonPackages = self: [ pkgs.glitchtip ];
- module = "glitchtip.wsgi:application";
- chdir = pkgs.glitchtip;
- http = ":8080";
- env = [
- "DATABASE_URL=postgres://glitchtrip@localhost:5432/glitchtrip"
- ];
- };
+ databaseUrl = "postgres://glitchtrip@localhost:5432/glitchtrip";
+ };
+ services.redis.servers.glitchtip = {
+ enable = true;
+ port = 6379;
};
+
services.tlp = {
enable = true;
settings = {