summaryrefslogtreecommitdiff
path: root/hosts/flora/services/pleroma.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/flora/services/pleroma.nix')
-rw-r--r--hosts/flora/services/pleroma.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/hosts/flora/services/pleroma.nix b/hosts/flora/services/pleroma.nix
index a76a9eb..fca9d65 100644
--- a/hosts/flora/services/pleroma.nix
+++ b/hosts/flora/services/pleroma.nix
@@ -19,17 +19,18 @@ in
config = {pkgs, config, ...}: {
- # pleroma is only on unstable for now, so import it here
- imports = [ "${sources.nixpkgs-unstable}/nixos/modules/services/networking/pleroma.nix" ];
# generating the manual will fail when mixing nixos channels,
# so disable it here or this won't build at all.
documentation.enable = false;
# pleroma has a cli tool for configuration
- environment.systemPackages = [ pkgs.pleroma pkgs.dnsutils ];
+ environment.systemPackages = [ pkgs.dnsutils ];
services.pleroma = {
enable = true;
+
+
+ package = (import sources.nixpkgs-unstable {}).pleroma;
# this is barely necessary at this point — all that's
# set in here is the default_signer for joken, and the