summaryrefslogtreecommitdiff
path: root/hosts/flora/services/nginx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/flora/services/nginx.nix')
-rw-r--r--hosts/flora/services/nginx.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/hosts/flora/services/nginx.nix b/hosts/flora/services/nginx.nix
new file mode 100644
index 0000000..5d21a14
--- /dev/null
+++ b/hosts/flora/services/nginx.nix
@@ -0,0 +1,21 @@
+{ config, lib, pkgs, ... }:
+
+{
+ networking.firewall.allowedTCPPorts = [ 80 443 ];
+
+ services.nginx = {
+ enable = true;
+
+ recommendedOptimisation = true;
+ recommendedTlsSettings = true;
+ recommendedProxySettings = true;
+
+ # virtualHosts = {
+ # "stuebinm.eu" = {
+ # forceSSL = true;
+ # enableACME = true;
+ # root = "/var/www/stats";
+ # };
+ # };
+ };
+}