summaryrefslogtreecommitdiff
path: root/hosts/chaski/services/uplcg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/chaski/services/uplcg.nix')
-rw-r--r--hosts/chaski/services/uplcg.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/hosts/chaski/services/uplcg.nix b/hosts/chaski/services/uplcg.nix
new file mode 100644
index 0000000..d2494bd
--- /dev/null
+++ b/hosts/chaski/services/uplcg.nix
@@ -0,0 +1,27 @@
+{ config, lib, pkgs, ... }:
+
+let
+ uplcg-nix = builtins.fetchGit {
+ url = "https://stuebinm.eu/git/uplcg";
+ };
+in
+{
+ imports = [
+ "${uplcg-nix.outPath}/module.nix"
+ ];
+
+ services.uplcg = {
+ enable = true;
+ port = 9080;
+ domain = "0.0.0.0";
+ };
+
+ services.nginx.virtualHosts."cards.stuebinm.eu" = {
+ locations."/" = {
+ proxyPass = "http://localhost:9080";
+ proxyWebsockets = true;
+ };
+ enableACME = true;
+ forceSSL = true;
+ };
+}