summaryrefslogtreecommitdiff
path: root/hosts/chaski/services/exneuland.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/chaski/services/exneuland.nix')
-rw-r--r--hosts/chaski/services/exneuland.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/hosts/chaski/services/exneuland.nix b/hosts/chaski/services/exneuland.nix
index a0c765a..3ec3451 100644
--- a/hosts/chaski/services/exneuland.nix
+++ b/hosts/chaski/services/exneuland.nix
@@ -20,7 +20,7 @@ in
{
services.nginx = {
enable = true;
- recommendedProxySettings = true;
+ recommendedProxySettings = false;
virtualHosts."exneuland.stuebinm.eu" = {
root = "${frontdrv}/dist";
locations."/_/".tryFiles = "/index.html =404";
@@ -30,6 +30,14 @@ in
proxyWebsockets = true;
extraConfig = ''
add_header Access-Control-Allow-Origin https://exneuland.stuebinm.eu;
+ proxy_pass_request_headers on;
+ proxy_set_header Host $host;
+ proxy_set_header X-Real-IP $remote_addr;
+ proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
+ proxy_set_header X-Forwarded-Proto $scheme;
+ proxy_set_header X-Forwarded-Host $http_host;
+ proxy_set_header Upgrade $http_upgrade;
+ proxy_set_header Connection $http_connection;
'';
};