summaryrefslogtreecommitdiff
path: root/hosts/chaski/services/cgit.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/chaski/services/cgit.nix')
-rw-r--r--hosts/chaski/services/cgit.nix18
1 files changed, 16 insertions, 2 deletions
diff --git a/hosts/chaski/services/cgit.nix b/hosts/chaski/services/cgit.nix
index abe69e5..7ce041c 100644
--- a/hosts/chaski/services/cgit.nix
+++ b/hosts/chaski/services/cgit.nix
@@ -11,7 +11,7 @@
hostPath = "/var/git/public";
isReadOnly = true;
};
-
+
config = {pkgs, config, ...}: {
services.lighttpd.enable = true;
services.lighttpd.extraConfig = ''server.use-ipv6 = "enable"'';
@@ -75,5 +75,19 @@
};
services.nginx.recommendedProxySettings = true;
- services.nginx.virtualHosts."stuebinm.eu".locations."/git/".proxyPass = "http://[${config.containers.cgit.localAddress6}]";
+ services.nginx.virtualHosts."stuebinm.eu" = {
+ locations."/git/".proxyPass = "http://[${config.containers.cgit.localAddress6}]";
+ enableACME = true;
+ forceSSL = true;
+ };
+
+ # user for git repo administration
+ users.users.git = {
+ openssh.authorizedKeys.keys = config.users.users.root.openssh.authorizedKeys.keys;
+ home = "/var/git";
+ isNormalUser = true;
+ };
+
+ networking.firewall.allowedTCPPorts = [ 80 443 ];
+
}